Troubleshooting Connectivity and Streaming Issues on Intel RealSense D400 Series Cameras on Linux

Symptoms:

  • RealSense software tools do not recognize the camera at all.
  • Cannot see streams–Depth, IR, RGB–or streams are not available in RealSense Viewer or other application.

 

Possible Causes

  • Camera is not connected to a USB 3 port
  • Faulty installation of librealsense
  • Unsupported Linux kernel

 

Workarounds

  • Connect the camera to a USB 3 port.
  • Upgrade the camera’s firmware.
  • USB 2.0 is supported but fewer streams are available. See the datasheet for RealSense D400 Depth cameras for more information on supported streams when connecting the camera to a USB 2 port.
  • Patch the kernel as needed following these instructions.
  • See this page for more Troubleshooting information.

 

Collect logs

  • Plug in the RealSense Camera D4xx into a USB port, open a terminal, and type:

               i.   “lsusb -v | tee lsusb_4xx.log”

             ii.   “dmesg | tee dmesg_4xx.log”

  • Contact Intel Customer Support and attach log files to case.